Go Back   Chevy Sonic Owners Forum > Chevy Sonic: Engine > 1.4L Turbo Sonic Engine Discussion

Like Tree1Likes
  • 1 Post By UltimaSanctus
Reply
 
LinkBack Thread Tools Display Modes
Old 08-12-2017, 08:44 PM   #1
Junior Member
 
Join Date: Jun 2017
Posts: 20
Garage
Default Random high idle problem

After my car is warmed up, driven maybe 20 highway miles and now onto side roads, I get a random high (12-1500) RPM rev up. My foots not hitting the gas and it usually happens when coming to a stop light and in nuetral or going to nuetral. It will last for 2-4 seconds and would t do it again for a few days. Anyone have a clue? Found nothing on the web other than rough idle for PCV. Thank you l in advance.
EyeluvSmegma is online now   Reply With Quote
Old 08-13-2017, 03:25 AM   #2
Senior Member
 
Llia's Avatar
 
Join Date: Mar 2016
Posts: 429
Garage
Default

What year is your car? Mileage?
Llia is online now   Reply With Quote
Old 08-13-2017, 01:11 PM   #3
Junior Member
 
Join Date: Jun 2017
Posts: 20
Garage
Default

Quote:
Originally Posted by Llia View Post
What year is your car? Mileage?

2013 1.4 6spd. Has 42,000 on the clock
EyeluvSmegma is online now   Reply With Quote
Old 08-14-2017, 11:43 PM   #4
Senior Member
 
Llia's Avatar
 
Join Date: Mar 2016
Posts: 429
Garage
Default

Does it happen when the A/C or heater is running? Possibly at full blast?
Llia is online now   Reply With Quote
Old 08-15-2017, 03:31 AM   #5
Junior Member
 
Join Date: Jun 2017
Posts: 20
Garage
Default

Quote:
Originally Posted by Llia View Post
Does it happen when the A/C or heater is running? Possibly at full blast?
I usually don't have the AC on.... Happens without it on. I know it will idle up on the seldom times I do use it, but it's a steady 100-150 rpm increase.
The issue I'm having is comparable to sitting in your car in the driveway and goosing the gas to 1500_2000 and holding it there for a second. Sometimes its quick and others I have to bump the gas pedal and it's back to normal for a few days. It's the weirdest thing really. I've changed my valve cover, MAF, detuned it, put my stock I take back on. The only thing I haven't taken off is my exhaust/downpipe. Only does it coming out of gear going to "N" or in "N" when I very first start to coast to a light or stop

Last edited by EyeluvSmegma; 08-15-2017 at 03:35 AM.
EyeluvSmegma is online now   Reply With Quote
Old 08-15-2017, 03:17 PM   #6
Member
 
Join Date: Jul 2016
Posts: 59
Garage
Default

Im actually curious as to what this is cause i havethe same random issue. Usually happens when im coming to a stop and pull it out of gear at lets say 20mph it will give a slight rev as if i was going to rev match and downshift. I did hear a thing about these computers "learning" our driving styles so maybe it is trying to help rev match. Probably not
EyeluvSmegma likes this.
UltimaSanctus is online now   Reply With Quote
Old Yesterday, 01:06 AM   #7
Junior Member
 
Join Date: Jun 2017
Posts: 20
Garage
Default

Quote:
Originally Posted by UltimaSanctus View Post
Im actually curious as to what this is cause i havethe same random issue. Usually happens when im coming to a stop and pull it out of gear at lets say 20mph it will give a slight rev as if i was going to rev match and downshift. I did hear a thing about these computers "learning" our driving styles so maybe it is trying to help rev match. Probably not
I'm guessing we are the only 2 with this issue?
EyeluvSmegma is online now   Reply With Quote
Old Today, 12:52 AM   #8
Junior Member
 
Join Date: Aug 2017
Posts: 14
Default

I get it too. It's usually a vacuum leak of some sort. But due to fly by wire, and emissions, it could possibly open throttle briefly to reduce emissions. By vacuum leak it could be many factors like a slow response pcv.

Until the rpms hang for a while, I'm not bothered. It's a minor thing and I think it could really be emissions related. Datalog could solve the mystery.
Ian_12 is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 08:32 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.