Go Back   Chevy Sonic Owners Forum > Chevrolet Sonic: General > Chevy Sonic Owners Forum

Reply
 
LinkBack Thread Tools Display Modes
Old 03-26-2017, 10:32 PM   #1
Junior Member
 
sarrm's Avatar
 
Join Date: Nov 2014
Posts: 19
Default P0442 engine code



Keep getting the p0442 code for about a year now. Just cant seem to get rid of it ! And that engine light is just so annoying to look at. Anyone have this and find the issue? Im being told that its the purge valve solenoid. I really dont think its the gas cap. Ive had it smoke tested and came back with no leaks. Any ideas? I really just dont want to go replacing things that dont need replacing and get it delt with the first time. Any input would be awesome. I have a 2012 chevy sonic ls hatchback with almost 85,000km.

Sent from my SM-G920W8 using Tapatalk
sarrm is offline   Reply With Quote
Old 03-27-2017, 03:55 PM   #2
Senior Member
 
JesusTheAgnostic's Avatar
 
Join Date: Dec 2015
Location: El Paso
Posts: 804
Default

P0442, that's malfunctioning cat right?
JesusTheAgnostic is online now   Reply With Quote
Old 03-27-2017, 09:51 PM   #3
Senior Member
 
Maddmatts's Avatar
 
Join Date: Aug 2012
Location: Manitoba, Canada
Posts: 506
Garage
Default

Google search implies that there's a small leak in the evaporative system because it can't hold a vacuum for a set amount of time.

Check the evap sytem hoses for looseness and holes/cracks. I think the purge solenoid sits on top of the intake manifold.
Maddmatts is offline   Reply With Quote
Old 03-28-2017, 05:59 PM   #4
Junior Member
 
sarrm's Avatar
 
Join Date: Nov 2014
Posts: 19
Default

Ok I will today thank you. I know aive googled it a bunch of times just wanna know exactly the problem lol

Sent from my SM-G920W8 using Tapatalk
sarrm is offline   Reply With Quote
Old 05-14-2017, 01:38 AM   #5
Junior Member
 
Join Date: May 2017
Location: NE Ohio
Posts: 11
Default

Wow,
I have the same code; cleared it, and it comes back (after about 3 weeks).
Please post what hose/fitting was the culprit.

Tom

Last edited by tsut; 05-14-2017 at 01:49 AM.
tsut is offline   Reply With Quote
Old 05-15-2017, 08:51 PM   #6
Senior Member
 
Join Date: Apr 2016
Location: connecticut
Posts: 208
Garage
Default

fill up with gas.
leave the cap off.
start the car.
if it surges (sounds like it's trying to stall out) replace the solenoid on top of the manifold.
__________________
Im the drunk ahole on the forum

14 RS manual- Zspec wheels, MFab intake, Zzp highflow catback RS muffler, Camaro Brake Swap, full LED/ ZXE swap, Rokblokz mudflaps, plenty of vinyls and spray paint to go around.

02 S10 2.2 turbo. Please don't ask why.
minitrucking02 is offline   Reply With Quote
Old 08-22-2017, 11:12 PM   #7
Junior Member
 
sarrm's Avatar
 
Join Date: Nov 2014
Posts: 19
Default

It was the purge valve solenoid
Finally delt with it
Apparently it was stuck open

Sent from my SM-G950W using Tapatalk
sarrm is offline   Reply With Quote
Reply



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 07:44 PM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.