Go Back   Chevy Sonic Owners Forum > Chevrolet Sonic: General > General Discussion

Reply
 
LinkBack Thread Tools Display Modes
Old 08-16-2013, 02:50 PM   #1
Junior Member
 
Join Date: Aug 2013
Location: Baltimore Maryland
Posts: 1
Default HID problems! Help!

So, I bought a set of 8000k Hids for my 2013 sonic, I had the shop install them, and tbey worked fine for about an hour. I came home and parked, than went to show someone the lights a little later and they started to flicker, than the driver side light went and never came back on. I tested the bulbs and ballests and there fine. Once I put my stock bulbs back in, everything functioned normaly. Wth is going on!
BmoreSonic is offline   Reply With Quote
Old 08-16-2013, 03:07 PM   #2
Lead Foot
 
Natesriv's Avatar
 
Join Date: Feb 2013
Location: Kansas City
Posts: 4,196
Garage
Default

back to shop!
__________________
https://s-media-cache-ak0.pinimg.com/736x/de/20/50/de2050af4e1474403e8da25727cf9364.jpg
Natesriv is offline   Reply With Quote
Old 08-16-2013, 03:08 PM   #3
Senior Member
 
SouthFLSonic's Avatar
 
Join Date: Oct 2012
Location: Ft Myers - Naples FL
Posts: 1,923
Garage
Default

Yeah if you paid for it to be installed it isn't a problem for you to fix it is a problem for the shop to fix. Go back tell them what happened and have them figure it out.
__________________
SouthFLSonic is online now   Reply With Quote
Old 08-16-2013, 03:14 PM   #4
Senior Member
 
Beastlick's Avatar
 
Join Date: Sep 2012
Location: Milwaukee, WI
Posts: 1,156
Garage
Default

if it wasnt light enough in the shop, the DRL's wouldnt be on causing no issues. If they didn't install a relay, as soon as its light enough they will most likely flicker. Try flipping your headlights to the on position to see if that made any difference. Most likely a wiring issue if that made no difference.
__________________
Beastlick Design

- Custom grilles
- Window vents
- Headlight retrofits

Instagram: Beastlick
Beastlick is offline   Reply With Quote
Old 08-16-2013, 04:00 PM   #5
Senior Member
 
sonic007's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach, Fl
Posts: 2,534
Default

Quote:
Originally Posted by Beastlick View Post
if it wasnt light enough in the shop, the DRL's wouldnt be on causing no issues. If they didn't install a relay, as soon as its light enough they will most likely flicker. Try flipping your headlights to the on position to see if that made any difference. Most likely a wiring issue if that made no difference.
I agree with this. The shops are usually a bit darker than outside so the nighttime lights were probably on. Did you drive home with the headlight switch on or were the drls on?
__________________
BEST BUY LEAD AUTOTECH MECP ADVANCED
3X SOTM WINNER
sonic007 is offline   Reply With Quote
Old 08-16-2013, 04:09 PM   #6
Senior Member
 
radsonic08's Avatar
 
Join Date: Aug 2013
Posts: 157
Default

i had the same problem i installed mine they worked fine right away driving down the road they would randomly turn off i had to flicker them to get them going some times just one i added a relay off of amazon no issues since then. just add a relay done deal
radsonic08 is offline   Reply With Quote
Old 08-16-2013, 04:18 PM   #7
Member
 
SlayerAk23's Avatar
 
Join Date: May 2013
Location: IL
Posts: 74
Garage
Default

Look into an Error Code Canceler (I think that's what they're called). My dad's friend installs HIDs at his vinyl shop and he said that in newer cars the computer sends pulsing DC to the lights. The canceler is a capacitor that slows the pulses so the ballasts could use the power right from the stock headlight harness. I have them on my sonic and they fixed my flashing HIDs.
SlayerAk23 is offline   Reply With Quote
Old 08-16-2013, 04:59 PM   #8
Senior Member
 
sonic007's Avatar
 
Join Date: Apr 2012
Location: Daytona Beach, Fl
Posts: 2,534
Default

Ran a relay to mine. No issues.
__________________
BEST BUY LEAD AUTOTECH MECP ADVANCED
3X SOTM WINNER
sonic007 is offline   Reply With Quote
Old 08-04-2015, 09:39 PM   #9
Member
 
calmb4dastorm's Avatar
 
Join Date: May 2013
Posts: 76
Default

2 curious questions:

1 > has anyone thought of just covering up the light sensor? that way the computer thinks it always dark?

2 > (serious question) what is this relay everyone has been getting? Where are you getting it? cost? Picture for reference? and, how to instal?

ok ok. Technically that was 7 questions. lol.
calmb4dastorm is offline   Reply With Quote
Old 08-04-2015, 09:49 PM   #10
Senior Member
 
4g63gst20's Avatar
 
Join Date: Apr 2013
Posts: 272
Default

I just disconnect mine so my lights come on all the time.
4g63gst20 is offline   Reply With Quote
Reply

Tags
lights, mods, probs, sonic



Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.